Opened 6 years ago

Closed 6 years ago

#3050 closed defect (duplicate)

library.mak uses strip flags (-wN) that assumes GNU strip

Reported by: nieder Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Building ffmpeg git on OS X spits out tons of non-fatal errors about unrecognized strip options:

STRIP	libavcodec/x86/h264_weight_10bit.o
strip: unrecognized option: -wN
Usage: strip [-AnuSXx] [-] [-d filename] [-s filename] [-R filename] [-o output] file [...] 
make: [libavcodec/x86/h264_weight_10bit.o] Error 1 (ignored)

Caused by 3d5a995eac2a47ac116c3412b364c0d21717829b from a merged libav commit.

OS X strip does not have either of those two flags.

Change History (1)

comment:1 Changed 6 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #3037.

Note: See TracTickets for help on using tickets.