Opened 6 years ago

Closed 6 years ago

#2403 closed defect (duplicate)

SSA sub unsync / resync

Reported by: Ricky1252 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Im trying to sync ssa/ass subtitles for burnin streaming but whenever the stream changes time, ie -ss 60, the ass will start back at beginning instead of seeking to position. -ss after input results in subtitle overlap of beginning and current time.

How to reproduce:

% ffmpeg -ss 60 -i abc.mkv -vf ass=abc.ass -y abc.mp4


ffmpeg version
ffmpeg -ss 60 -i abc.mkv -vf ass=abc.ass -y abc.mp4ffmpeg version N-51205-gac9b056 
Copyright (c) 2000-2013 the FFmpeg developers
  built on Mar 22 2013 05:22:54 with gcc 4.6 (Debian 4.6.3-1)
  configuration: --prefix=/root/ffmpeg-static/64bit 
--extra-cflags='-I/root/ffmpeg-static/64bit/include 
-static' --extra-ldflags='-L/root/ffmpeg-static/64bit/lib 
-static' --extra-libs='-lxml2 -lexpat -lfreetype' --enable-static 
--disable-shared --disable-ffserver --disable-doc --enable-bzlib 
--enable-zlib --enable-postproc --enable-runtime-cpudetect 
--enable-libx264 --enable-gpl --enable-libtheora --enable-libvorbis 
--enable-libmp3lame --enable-gray --enable-libass --enable-libfreetype 
--enable-libopenjpeg --enable-libspeex --enable-libvo-aacenc 
--enable-libvo-amrwbenc --enable-version3 --enable-libvpx
  libavutil      52. 22.100 / 52. 22.100
  libavcodec     55.  1.100 / 55.  1.100
  libavformat    55.  0.100 / 55.  0.100
  libavdevice    55.  0.100 / 55.  0.100
  libavfilter     3. 48.100 /  3. 48.100
  libswscale      2.  2.100 /  2.  2.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  2.100 / 52.  2.100

Change History (1)

comment:1 Changed 6 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Keywords SSA sub unsync / resync removed
  • Resolution set to duplicate
  • Status changed from new to closed

This sounds like a duplicate of ticket #2067, please test again once that ticket is fixed.

Note: See TracTickets for help on using tickets.