Opened 6 years ago

Closed 6 years ago

#2393 closed defect (fixed)

H264 raw files and decode_slice_header error

Reported by: fedech Owned by:
Priority: important Component: avcodec
Version: 1.0.6 Keywords: h264 regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Hello, I have a problem with raw .h264 files and ffmpeg 1.0 (everything works in 0.8 on another machine): when I try to convert them to mp4 or play them in ffplay I get a ton of errors (reproduced below), but mplayer plays them fine. I used some of the files from http://www2.tkn.tu-berlin.de/research/evalvid/cif.html
How to reproduce:

% ffmpeg -i highway_cif.264 
ffmpeg version 1.0
built on Linux Mint Debian Edition (Debian testing repos)

I copied here the first lines of the CL output, the complete log is in the attachment:

[h264 @ 0x24c3100] brainfart cropping not supported, cropping disabled (right: 1, bottom: 87)

Last message repeated 1 times

[h264 @ 0x24c3100] top block unavailable for requested intra4x4 mode -1 at 0 0
[h264 @ 0x24c3100] error while decoding MB 0 0, bytestream (69249)
[h264 @ 0x24c3100] concealing 24 DC, 24 AC, 24 MV errors in I frame
[h264 @ 0x24c3100] QP 5738 out of range
[h264 @ 0x24c3100] decode_slice_header error
[h264 @ 0x24c3100] concealing 24 DC, 24 AC, 24 MV errors in P frame
[h264 @ 0x24c3100] QP 9834 out of range
[h264 @ 0x24c3100] decode_slice_header error
[h264 @ 0x24c3100] concealing 24 DC, 24 AC, 24 MV errors in P frame
[h264 @ 0x24c3100] deblocking_filter_idc 32 out of range
[h264 @ 0x24c3100] decode_slice_header error
[h264 @ 0x24c3100] concealing 24 DC, 24 AC, 24 MV errors in P frame
[h264 @ 0x24c3100] illegal memory management control operation 32
[h264 @ 0x24c3100] illegal short term buffer state detected
[h264 @ 0x24c3100] cabac_init_idc overflow
[h264 @ 0x24c3100] decode_slice_header error
[h264 @ 0x24c3100] mmco: unref short failure
[h264 @ 0x24c3100] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x24c3100] concealing 24 DC, 24 AC, 24 MV errors in P frame
[h264 @ 0x24c3100] cabac_init_idc overflow
[h264 @ 0x24c3100] decode_slice_header error
[h264 @ 0x24c3100] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x24c3100] concealing 24 DC, 24 AC, 24 MV errors in P frame
[h264 @ 0x24c3100] QP 3789 out of range
[h264 @ 0x24c3100] decode_slice_header error
[h264 @ 0x24c3100] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x24c3100] concealing 24 DC, 24 AC, 24 MV errors in P frame
[h264 @ 0x24c3100] illegal reordering_of_pic_nums_idc
[h264 @ 0x24c3100] decode_slice_header error
[h264 @ 0x24c3100] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x24c3100] concealing 24 DC, 24 AC, 24 MV errors in P frame
[h264 @ 0x24c3100] cabac_init_idc overflow
[h264 @ 0x24c3100] decode_slice_header error
[h264 @ 0x24c3100] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x24c3100] concealing 24 DC, 24 AC, 24 MV errors in P frame
[h264 @ 0x24c3100] abs_diff_pic_num overflow
[h264 @ 0x24c3100] decode_slice_header error
[h264 @ 0x24c3100] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x24c3100] concealing 24 DC, 24 AC, 24 MV errors in P frame
[h264 @ 0x24c3100] long_term_pic_idx overflow
[h264 @ 0x24c3100] decode_slice_header error
[h264 @ 0x24c3100] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x24c3100] concealing 24 DC, 24 AC, 24 MV errors in P frame
[h264 @ 0x24c3100] abs_diff_pic_num overflow

Attachments (2)

stdout.txt (19.9 KB) - added by fedech 6 years ago.
highway_cif_cut.264 (2.0 MB) - added by cehoyos 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by fedech

comment:1 Changed 6 years ago by cehoyos

  • Keywords h264 added; H264 decode_slice_header error removed

Please provide the input file.

comment:2 Changed 6 years ago by fedech

http://www2.tkn.tu-berlin.de/research/evalvid/cif/highway_cif.264 is the one the output I posted came from, but the same thing happens with any video from the Evalvid sample folder I linked to in my first post

comment:3 Changed 6 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from 1.0.5 to 1.0.6

Thank you for opening this ticket, for future reports, please provide complete, uncut console output.

This will be fixed in 1.0.7, since the problem is not reproducible with any higher release, please consider to update to 1.2 or current git head.

$ ffmpeg -i highway_cif_cut.264
ffmpeg version 1.0.6 Copyright (c) 2000-2013 the FFmpeg developers
  built on Mar 21 2013 23:51:54 with gcc 4.7 (SUSE Linux)
  configuration:
  libavutil      51. 73.101 / 51. 73.101
  libavcodec     54. 59.100 / 54. 59.100
  libavformat    54. 29.104 / 54. 29.104
  libavdevice    54.  2.101 / 54.  2.101
  libavfilter     3. 17.100 /  3. 17.100
  libswscale      2.  1.101 /  2.  1.101
  libswresample   0. 15.100 /  0. 15.100
[h264 @ 0x17b27e0] brainfart cropping not supported, cropping disabled (right: 1, bottom: 87)
    Last message repeated 1 times
[h264 @ 0x17b27e0] top block unavailable for requested intra4x4 mode -1 at 0 0
[h264 @ 0x17b27e0] error while decoding MB 0 0, bytestream (69249)
[h264 @ 0x17b27e0] concealing 24 DC, 24 AC, 24 MV errors in I frame
[h264 @ 0x17b27e0] QP 5738 out of range
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] QP 9834 out of range
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] deblocking_filter_idc 32 out of range
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] illegal memory management control operation 32
[h264 @ 0x17b27e0] illegal short term buffer state detected
[h264 @ 0x17b27e0] cabac_init_idc overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] mmco: unref short failure
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] cabac_init_idc overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] QP 3789 out of range
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] illegal reordering_of_pic_nums_idc
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] cabac_init_idc overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] abs_diff_pic_num overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] long_term_pic_idx overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] abs_diff_pic_num overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] reference picture missing during reorder
[h264 @ 0x17b27e0] reference count overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] reference picture missing during reorder
[h264 @ 0x17b27e0] reference count overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] reference picture missing during reorder
[h264 @ 0x17b27e0] reference count overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] reference overflow 16793 > 15 or 0 > 15
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] Missing reference picture, default is 65536
    Last message repeated 6 times
[h264 @ 0x17b27e0] cabac_init_idc overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] Missing reference picture, default is 65536
    Last message repeated 2 times
[h264 @ 0x17b27e0] cabac_init_idc overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] Missing reference picture, default is 65536
    Last message repeated 4 times
[h264 @ 0x17b27e0] cabac_init_idc overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] Missing reference picture, default is 65536
[h264 @ 0x17b27e0] cabac_init_idc overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] illegal reordering_of_pic_nums_idc
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] Missing reference picture, default is 65536
    Last message repeated 1 times
[h264 @ 0x17b27e0] cabac_init_idc overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] illegal reordering_of_pic_nums_idc
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] cabac_init_idc overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] QP 4294966484 out of range
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] illegal memory management control operation 32
[h264 @ 0x17b27e0] cabac_init_idc overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] cabac_init_idc overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] illegal reordering_of_pic_nums_idc
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] abs_diff_pic_num overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17b27e0] abs_diff_pic_num overflow
[h264 @ 0x17b27e0] decode_slice_header error
[h264 @ 0x17b27e0] number of reference frames (1+1) exceeds max (0; probably corrupt input), discarding one
[h264 @ 0x17ac280] decoding for stream 0 failed
[h264 @ 0x17ac280] Estimating duration from bitrate, this may be inaccurate
Input #0, h264, from 'highway_cif_cut.264':
  Duration: N/A, bitrate: N/A
    Stream #0:0: Video: h264 (High 4:4:4), yuv420p, 192x32, 25 fps, 25 tbr, 1200k tbn, 50 tbc
At least one output file must be specified

Changed 6 years ago by cehoyos

comment:4 Changed 6 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed in release/1.0.

Note: See TracTickets for help on using tickets.