Opened 4 years ago

Last modified 2 years ago

#2387 reopened enhancement

Support DVD sub rasterization

Reported by: someuser Owned by:
Priority: wish Component: undetermined
Version: git-master Keywords: dvdsub
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
It would be great if FFmpeg could create VobSub? idx/sub subtitles to be used with avi files as it would allow FFmpeg to be used to add subtitles to avi files without reencoding. Devices like PS3 are able play such files.

Usage would be something like (perhaps with -f vobsub):

% ffmpeg -i test-en.srt test-en.idx

Ticket #2385 is somewhat related.

Change History (6)

comment:1 in reply to: ↑ description Changed 4 years ago by someuser

Replying to someuser:

Usage would be something like (perhaps with -f vobsub):

% ffmpeg -i test-en.srt test-en.idx

Well, after thinking about this few minutes more, the usage can't of course be this simple since some sort of size/coordinate information for the bitmaps would be required.

Ticker #2385 also contains an example .idx file which might give ideas what information would be needed for generating proper .idx/.sub files for an AVI.

comment:2 Changed 2 years ago by edumj

Hi,

so there is no way to extract idx/sub from a VOB with ffmpeg?

It seems that Mencoder can do so http://www.cs.ait.ac.th/~on/mplayer/en/menc-feat-extractsub.html

And here http://ffmpeg-users.933282.n4.nabble.com/extract-subtiles-td939612.html says it can be done with "-bsf mov2textsub", but only exports one .txt file with unkwown format

Here http://ffmpeg.org/pipermail/ffmpeg-devel/2006-October/018399.html says something like that, but doesn't work.

comment:3 Changed 2 years ago by ubitux

  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from RFE: Support creating of VobSub idx/sub subtitles to Support DVD sub rasterization

Not yet unfortunately, #2391 is related.

This ticket suggests a rasterisation though, so title updated.

Last edited 2 years ago by ubitux (previous) (diff)

comment:4 Changed 2 years ago by ubitux

  • Keywords dvdsub added
  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:5 Changed 2 years ago by edumj

Ok, but is it possible just to extract DVD subtitules as idx/sub files? like Mencoder does http://www.cs.ait.ac.th/~on/mplayer/en/menc-feat-extractsub.html

comment:6 Changed 2 years ago by ubitux

Not yet, see ticket #2391.

Note: See TracTickets for help on using tickets.