Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#2358 closed defect (fixed)

auto downscale ffplay sdl windows regression

Reported by: burek Owned by:
Priority: normal Component: ffplay
Version: git-master Keywords: win regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
The entire thread can be viewed here: http://ffmpeg.gusari.org/viewtopic.php?f=26&t=856

How to reproduce:

ffplay -i "FileName"

and after that pressing the "F" key.

This version of ffplay works as expected: http://ffmpeg.zeranoe.com/builds/win32/static/ffmpeg-git-41a097a-win32-static.7z

This version does not work: http://ffmpeg.zeranoe.com/builds/win32/static/ffmpeg-20121105-git-c995644-win32-static.7z

So this is possibly a regression of some sort and should be investigated.

Change History (15)

comment:1 Changed 6 years ago by cehoyos

Please add the complete, uncut console output of your failing command.
If this is a regression, please find the change introducing it.

comment:2 Changed 6 years ago by burek

Please read the forum post.

comment:3 Changed 6 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen if you can add the missing information.

comment:4 follow-up: Changed 6 years ago by compn

carl , can you leave these bugs open so others can work on them, even if they dont have the information in the trac?

comment:5 in reply to: ↑ 4 Changed 6 years ago by cehoyos

Replying to compn:

carl , can you leave these bugs open so others can work on them, even if they dont have the information in the trac?

Why don't you read the forum entry, reproduce the ticket, add the missing information here and reopen the ticket? (If the problem really is Zeranoe-only, it will probably help more to either post on his forum or contact him directly, I suspect he is not following this tracker regularly.)

comment:6 follow-up: Changed 6 years ago by michael

This ticket is missing information about how to reproduce the problem as well as a description of the problem. It may be on the linked forum but that is IMHO not ok. copy and pasting at least 1 paragraph or writing a summary is neccessary. I also tried ffplay random file and "f" switched to fullscreen as expected
so iam no smarter from that.

comment:7 in reply to: ↑ 6 Changed 6 years ago by ubitux

Replying to michael:

This ticket is missing information about how to reproduce the problem as well as a description of the problem. It may be on the linked forum but that is IMHO not ok. copy and pasting at least 1 paragraph or writing a summary is neccessary. I also tried ffplay random file and "f" switched to fullscreen as expected
so iam no smarter from that.

I agree with this for one simple reason: the ticket will still be understandable in 1, 2, 3, or 10 years even if the forum doesn't exist anymore.

On a practical note, it's also handy for developers not to have to crawl another forum thread just to pick hints on the problem.

comment:8 Changed 6 years ago by burek

ok, i'll avoid reposting forum issues here in the future and let people decide if they want to do it themselves. it's even easier for me that way, but it will be ffmpeg project's lost.. after all ffmpeg needs bug reports, and those users that experience those issues probably won't have time nor will to report anything, they'll probably move to another tool/player or they will wait for some time and check if the bug is gone.. the grand total is that ffmpeg is loosing the information it needs, the end users will quickly adopt to some other tools even if ffmpeg project dies at some point (god forbid).. so, for users, it's not a big deal, but i guess for ffmpeg it is..

imho it is far better to leave some (maybe even invalid) tickets open (i mean it's not like they cause cancer or something), rather than close them pretending they never existed :) it looks to me as if some people are afraid of open tickets and they close them as soon as they find any reason to do so, which is rather funny to me :)

comment:9 Changed 6 years ago by compn

  • Resolution needs_more_info deleted
  • Status changed from closed to reopened

if i must, i must... :)

i can report reproduction of bug. in old version, with desktop res set small , say 800x600 , if you open a file which is larger than the desktop res (say 1920x1080) then ffplay will automatically downscale the video when pressing f to fullscreen.

W:\mplayer-test>y:\ffplay-o 00001small.m2ts
ffplay version N-39494-g41a097a Copyright (c) 2003-2012 the FFmpeg developers

built on Apr 3 2012 20:20:04 with gcc 4.6.2
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-runtime-cpudetect --en

able-avisynth --enable-bzlib --enable-frei0r --enable-libopencore-amrnb --enable-libopencore-amrwb -
-enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-librtmp --enab
le-libschroedinger --enable-libspeex --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwben
c --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zli
b

libavutil 51. 44.100 / 51. 44.100
libavcodec 54. 12.100 / 54. 12.100
libavformat 54. 3.100 / 54. 3.100
libavdevice 53. 4.100 / 53. 4.100
libavfilter 2. 66.101 / 2. 66.101
libswscale 2. 1.100 / 2. 1.100
libswresample 0. 10.100 / 0. 10.100
libpostproc 52. 0.100 / 52. 0.100

[NULL @ 027A3840] start time is not set in estimate_timings_from_pts
[NULL @ 027A99A0] start time is not set in estimate_timings_from_pts
[mpegts @ 0218BE20] PES packet size mismatch
Input #0, mpegts, from '00001small.m2ts':

Duration: 00:00:03.12, start: 599.958300, bitrate: 26188 kb/s
Program 1

Stream #0:0[0x1011]: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p, 1920x1080 [SAR 1:1 DA

R 16:9], 23.98 fps, 23.98 tbr, 90k tbn, 47.95 tbc

Stream #0:1[0x1100](eng): Audio: truehd (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), s32
Stream #0:2[0x1100]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), s16, 640 kb/s
Stream #0:3[0x1101](rus): Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), s16, 384 kb/s
Stream #0:4[0x1200](rus): Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:5[0x1201](rus): Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)

[mpegts @ 0218BE20] PES packet size mismatch 0KB sq= 0B f=0/0 f=0/0
[h264 @ 0218CAA0] error while decoding MB 25 17, bytestream (td)0
[h264 @ 0218CAA0] concealing 6120 DC, 6120 AC, 6120 MV errors

618.76 A-V: 0.286 fd= 58 aq= 0KB vq= 0KB sq= 0B f=0/0

new version of ffplay just quits when pressing f if video size is greater than desktop res.

W:\mplayer-test>y:\ffplay 00001small.m2ts
ffplay version N-49448-gdc8dd2f Copyright (c) 2003-2013 the FFmpeg developers

built on Jan 29 2013 17:50:41 with gcc 4.7.2 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzli

b --enable-fontconfig --enable-frei0r --enable-gnutls --enable-libass --enable-libbluray --enable-li
bcaca --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-l
ibopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --e
nable-libspeex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwbenc
--enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib

libavutil 52. 17.100 / 52. 17.100
libavcodec 54. 91.100 / 54. 91.100
libavformat 54. 61.104 / 54. 61.104
libavdevice 54. 3.102 / 54. 3.102
libavfilter 3. 34.101 / 3. 34.101
libswscale 2. 2.100 / 2. 2.100
libswresample 0. 17.102 / 0. 17.102
libpostproc 52. 2.100 / 52. 2.100

[mpegts @ 025d7ec0] Stream #4: not enough frames to estimate rate; consider increasing probesize
[mpegts @ 025d7ec0] Stream #5: not enough frames to estimate rate; consider increasing probesize
[mpegts @ 025d7ec0] Could not find codec parameters for stream 4 (Subtitle: hdmv_pgs_subtitle ([144]
[0][0][0] / 0x0090)): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 025d7ec0] Could not find codec parameters for stream 5 (Subtitle: hdmv_pgs_subtitle ([144]
[0][0][0] / 0x0090)): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[NULL @ 0260db20] start time is not set in estimate_timings_from_pts
[NULL @ 02613b20] start time is not set in estimate_timings_from_pts
[mpegts @ 025d7ec0] PES packet size mismatch
Input #0, mpegts, from '00001small.m2ts':

Duration: 00:00:03.13, start: 599.958300, bitrate: 26188 kb/s
Program 1

Stream #0:0[0x1011]: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p, 1920x1080 [SAR 1:1 DA

R 16:9], 23.98 fps, 23.98 tbr, 90k tbn, 47.95 tbc

Stream #0:1[0x1100](eng): Audio: truehd (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), s32
Stream #0:2[0x1100]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), fltp, 640 kb/s
Stream #0:3[0x1101](rus): Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, 5.1(side), fltp, 384 kb/s
Stream #0:4[0x1200](rus): Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)
Stream #0:5[0x1201](rus): Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)

600.16 A-V:598.852 fd= 0 aq= 90KB vq= Frame changed from size:0x0 to size:1920x1080

[mpegts @ 025d7ec0] PES packet size mismatch 0KB sq= 0B f=0/0

602.96 A-V: 0.217 fd= 62 aq= 0K[h264 @ 025ddfc0] error while decoding MB 25 17, bytestream (-5

)
[h264 @ 025ddfc0] concealing 6120 DC, 6120 AC, 6120 MV errors in B frame
SDL: could not set video mode - exitingvq= 0KB sq= 0B f=0/0

comment:10 Changed 6 years ago by compn

  • Keywords ffplay added
  • Summary changed from ffplay SDL bug to auto downscale ffplay sdl windows regression

comment:11 Changed 6 years ago by cehoyos

Is the problem reproducible with the following commands?
$ ffmpeg -i tests/lena.pnm -s 4000x4000 out.png
$ ffplay out.png
(and do I understand correctly that ffplay -fs out.png works fine?)

comment:12 Changed 6 years ago by compn

ffplay out.png opens a video window. i am able to see the part of the image that fits on the screen. so i get to see a corner of the 4000x4000 image, due to my small desktop size.

ffplay -fs out.png does not open any video window.

W:\mplayer-test>y:\ffplay -fs out.png
ffplay version N-49448-gdc8dd2f Copyright (c) 2003-2013 the FFmpeg developers

built on Jan 29 2013 17:50:41 with gcc 4.7.2 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzli

b --enable-fontconfig --enable-frei0r --enable-gnutls --enable-libass --enable-libbluray --enable-li
bcaca --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-l
ibopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --e
nable-libspeex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwbenc
--enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib

libavutil 52. 17.100 / 52. 17.100
libavcodec 54. 91.100 / 54. 91.100
libavformat 54. 61.104 / 54. 61.104
libavdevice 54. 3.102 / 54. 3.102
libavfilter 3. 34.101 / 3. 34.101
libswscale 2. 2.100 / 2. 2.100
libswresample 0. 17.102 / 0. 17.102
libpostproc 52. 2.100 / 52. 2.100

[image2 @ 025d7ea0] Stream #0: not enough frames to estimate rate; consider increasing probesize
Input #0, image2, from 'out.png':

Duration: 00:00:00.04, start: 0.000000, bitrate: N/A

Stream #0:0: Video: png, rgb24, 4000x4000 [SAR 3:2 DAR 3:2], 25 tbr, 25 tbn, 25 tbc

Frame changed from size:0x0 to size:4000x4000q= 0KB vq= 0KB sq= 0B f=0/0
SDL: could not set video mode - exiting 0 aq= 0KB vq= 0KB sq= 0B f=0/0

ffplay also hangs here and needs ctrl-c to return back to cmd prompt.

if anyone wants me to test some ffmpeg revisions, i will be happy to.
bonus if you link me to the zeranoe static build you want me to test.

comment:13 follow-up: Changed 6 years ago by compn

also, viewing a small res video (smaller than my desktop res, say 720x480 on a 800x600 desktop resolution)
when i ffplay -fs file.jpg my monitor goes blank like when its changing the resolution. then it returns to normal and the jpg is on display in windowed mode.

if i press f again, nothing happens.
if i press f one more time, ffplay finally displays the small res file fullscreen.

ffplay out.png
press f once = rescaled image to 720x480 somehow?
press f twice = nothing happens, still windowed 720x480 image
press f three times = full screen properly scaled image

hope this clears it up ;)

comment:14 Changed 6 years ago by cehoyos

  • Component changed from undetermined to FFplay
  • Keywords win regression added; ffplay removed
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from reopened to closed
  • Version changed from unspecified to git-master

Regression since 5de3f72, related to ticket #2174.
Fixed in b94df21

comment:15 in reply to: ↑ 13 Changed 6 years ago by cehoyos

Replying to compn:

also, viewing a small res video (smaller than my desktop res, say 720x480 on a 800x600 desktop resolution)
when i ffplay -fs file.jpg my monitor goes blank like when its changing the resolution. then it returns to normal and the jpg is on display in windowed mode.

if i press f again, nothing happens.
if i press f one more time, ffplay finally displays the small res file fullscreen.

Please consider opening a new ticket for this issue.

Note: See TracTickets for help on using tickets.