Opened 6 years ago

Closed 3 years ago

#2324 closed defect (fixed)

Duplicate First Frame

Reported by: brchapman Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: mov edts
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:

When using ffmpeg to convert an h264 video stream from an mp4 to prores or mjpeg Quicktime, the first frame of video is duplicated in the result.

How to reproduce:

% ffmpeg -i test100.mp4 -c:v prores -an test100_ffmpeg.mov
ffmpeg version 1.1.git
git revision: faa0068
built on Mar  4 2013 11:40:27

Attachments (1)

test100.mp4 (433.1 KB) - added by brchapman 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by brchapman

comment:1 Changed 6 years ago by cehoyos

  • Keywords mov added; mp4 removed
  • Resolution set to duplicate
  • Status changed from new to closed

(For future tickets: Please always add complete, uncut console output together with the command line.)

FFmpeg's mov muxer does not support variable frame rate output, it therefore has to duplicate frames to produce a constant frame rate.

Several tickets are open that contain references to this limitation, in any case it is known.

comment:2 Changed 6 years ago by burek

It might help to start answering to people with "Thank you for your time spent to report this issue to us", rather then to just close it, not even mentioning what is it the duplicate of...

comment:3 Changed 6 years ago by cehoyos

  • Resolution duplicate deleted
  • Status changed from closed to reopened

There may actually be an issue, possibly the same as in ticket #2337

comment:4 Changed 3 years ago by richardpl

  • Reproduced by developer set
  • Status changed from reopened to open

comment:5 Changed 3 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords edts added
  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.